summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 01:26:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:07 -0400
commitdff469209e14b867b1f3f6e946526b4654cc4d08 (patch)
tree69cf1630044e75d6fe8899bec0c8ca46fd194e23
parentcecf1953475719b36716630f6765ae6b12631bb4 (diff)
downloadguix-patches-dff469209e14b867b1f3f6e946526b4654cc4d08.tar
guix-patches-dff469209e14b867b1f3f6e946526b4654cc4d08.tar.gz
gnu: python-flask-wtf: Update to 1.0.1.
* gnu/packages/python-web.scm (python-flask-wtf): Update to 1.0.1. [propagated-inputs]: Remove python-flask-babel and python-babel. Add python-flask and python-itsdangerous.
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 89b688da32..f98f824daa 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3249,14 +3249,14 @@ presume or force a developer to use a particular tool or library.")
(define-public python-flask-wtf
(package
(name "python-flask-wtf")
- (version "0.14.3")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-WTF" version))
(sha256
(base32
- "086pvg2x69n0nczcq7frknfjd8am1zdy8qqpva1sanwb02hf65yl"))))
+ "1jd614662r6ifh4svs8zfwm4k8bal5z3n6pq607bas8gxrpmrzil"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -3265,7 +3265,7 @@ presume or force a developer to use a particular tool or library.")
(lambda _
(invoke "pytest" "-vv"))))))
(propagated-inputs
- (list python-flask-babel python-babel python-wtforms))
+ (list python-flask python-itsdangerous python-wtforms))
(native-inputs
(list python-pytest))
(home-page "https://github.com/lepture/flask-wtf")