summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-21 22:29:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:09 -0400
commitea20078ccb098ee0e5a27cfed7efdf4fe9c7d799 (patch)
tree77765228d4e9a81c9eee9f6d5d677d53bcbc3875
parentbadd61bed29dadb148f64f9d21654b513441d057 (diff)
downloadguix-patches-ea20078ccb098ee0e5a27cfed7efdf4fe9c7d799.tar
guix-patches-ea20078ccb098ee0e5a27cfed7efdf4fe9c7d799.tar.gz
gnu: python-sphinx-cloud-sptheme: Update to 1.10.1 [still broken].
* gnu/packages/sphinx.scm (python-sphinx-cloud-sptheme): Update to 1.10.1. [source]: Update source to point to new Mercurial repository. [arguments]: Delete field, enabling tests (which fail due to Jinja2 >= 3.1). [native-inputs]: Move python-sphinx to... [propagated-inputs]: ... here. [description]: Do not use raw quotes to decorate text.
-rw-r--r--gnu/packages/sphinx.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 25dcff01be..4b485d53c0 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -38,6 +38,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix hg-download)
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system python)
@@ -701,25 +702,28 @@ theme for the Sphinx documentation system. It's the default theme of Sphinx.")
argparse commands and options")
(license license:expat)))
+;;; FIXME: Currently broken by Jinja >= 3.10 (see:
+;;; https://foss.heptapod.net/doc-utils/cloud_sptheme/-/issues/47).
(define-public python-sphinx-cloud-sptheme
(package
(name "python-sphinx-cloud-sptheme")
- (version "1.8.0")
+ (version "1.10.1")
(source (origin
- (method url-fetch)
- (uri (pypi-uri "cloud_sptheme" version))
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://foss.heptapod.net/doc-utils/cloud_sptheme")
+ (changeset version)))
+ (file-name (hg-file-name name version))
(sha256
(base32
- "1dniqb6a39yh786f86c4jn666rwnyi1jvzn4616zhcchb7sfdshd"))))
+ "0k0pgi0vcn8vdy3k6x11fpp4mqp7p3l6n6pjfi3mir3vwjhdfz7l"))))
(build-system python-build-system)
- ;; FIXME: The 'pypi' release archive does not contain tests.
- (arguments '(#:tests? #f))
- (native-inputs
- (list python-sphinx))
- (home-page "https://bitbucket.org/ecollins/cloud_sptheme")
- (synopsis "'Cloud' theme for Sphinx documenter")
- (description "This package contains the \"Cloud\" theme for Sphinx and some
-related extensions.")
+ (native-inputs (list python-mock))
+ (propagated-inputs (list python-sphinx))
+ (home-page "https://foss.heptapod.net/doc-utils/cloud_sptheme")
+ (synopsis "Cloud theme for Sphinx")
+ (description "This package contains the @emph{Cloud} theme for Sphinx and
+some related extensions.")
(license license:bsd-3)))
(define-public python-guzzle-sphinx-theme