summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 00:26:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:05 -0400
commite7b0d63e32407cdcaf405cb69c2e8e5e3e3fd5e2 (patch)
tree943f6c63abeced9a711ed2abbcd997302ba08457
parent213696b061de51f076e7ad2ab01fc76310a81be5 (diff)
downloadguix-patches-e7b0d63e32407cdcaf405cb69c2e8e5e3e3fd5e2.tar
guix-patches-e7b0d63e32407cdcaf405cb69c2e8e5e3e3fd5e2.tar.gz
gnu: Add python-pydyf.
* gnu/packages/pdf.scm (python-pydyf): New variable.
-rw-r--r--gnu/packages/pdf.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 5963401975..b791a2fc8b 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2020-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
@@ -701,6 +701,33 @@ for applications that wish to do lower level manipulation of PDF, such as
extracting content or merging files.")
(license license:lgpl2.0+)))
+(define-public python-pydyf
+ (package
+ (name "python-pydyf")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pydyf" version))
+ (sha256
+ (base32 "0b30g3hhxw1bg18r9ax85i1dkg8vy1y1wzas0bg0bxblh7j5sbqy"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-c" "/dev/null")))))))
+ (propagated-inputs (list python-pillow))
+ (native-inputs (list ghostscript python-pytest))
+ (home-page "https://github.com/CourtBouillon/pydyf")
+ (synopsis "Low-level PDF generator")
+ (description "@code{pydyf} is a low-level PDF generator written in Python
+and based on PDF specification 1.7.")
+ (license license:bsd-3)))
+
(define-public mupdf
(package
(name "mupdf")