summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-22 21:41:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:11 -0400
commitdfe81d0f812e012cb0cb7d6c89f8aea03b733038 (patch)
tree7e4fa38f4cafc505e8de97c89e4febf9d1f7be4b
parentb60ca1f3b83ae62194cd8ea7317f4aef3b2bc2e7 (diff)
downloadguix-patches-dfe81d0f812e012cb0cb7d6c89f8aea03b733038.tar
guix-patches-dfe81d0f812e012cb0cb7d6c89f8aea03b733038.tar.gz
gnu: Add python-ipdb.
* gnu/packages/python-xyz.scm (python-ipdb): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1140e29790..e99587cf67 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6278,6 +6278,32 @@ to the interactive prompt. It is an extension of the @code{rlcompleter}
module from the standard Python library.")
(license license:bsd-3)))
+(define-public python-ipdb
+ (package
+ (name "python-ipdb")
+ (version "0.13.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ipdb" version))
+ (sha256
+ (base32 "1ibql99agjf2gj7y0svzd5m0h81hailf4p3sj3yl9i1i8ykdj6wm"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover")))))))
+ (propagated-inputs (list python-ipython python-toml python-decorator))
+ (home-page "https://github.com/gotcha/ipdb")
+ (synopsis "IPython-enhanced Python debugger (pdb)")
+ (description "@code{ipdb} exports functions to access the IPython
+debugger, which features tab completion, syntax highlighting, better
+tracebacks and better introspection than Python's standard @command{pdb}
+debugger, with which it shares the same interface.")
+ (license license:bsd-3)))
+
(define-public python-pdbpp
(package
(name "python-pdbpp")