summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-04-25 11:38:04 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:12 -0400
commitdd50817dd661755c72e1a321e69e116c8044656e (patch)
treecbf167b725bb1123ef94a9ac63bc819283c958d9
parente3bb211c23cdd09a2f088baad2e68a4c7bbc2b82 (diff)
downloadguix-patches-dd50817dd661755c72e1a321e69e116c8044656e.tar
guix-patches-dd50817dd661755c72e1a321e69e116c8044656e.tar.gz
gnu: python-qtconsole: Update to 5.3.0.
* gnu/packages/python-xyz.scm (python-qtconsole): Update to 5.3.0. [native-inputs]: Add python-pytest-qt. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12ee339a80..fd0f51120e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14011,13 +14011,13 @@ Jupyter kernels such as IJulia and IRKernel.")
(define-public python-qtconsole
(package
(name "python-qtconsole")
- (version "4.7.7")
+ (version "5.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "qtconsole" version))
(sha256
- (base32 "013qgpsm8jzcz3prhq7sxs36l8f7fgagmn3xa010gfhxf7cfldpj"))))
+ (base32 "09anp8g7vqi8z8wyi2lv21a2frd2dyhyrzvcrk2anijyqzyj0dcf"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -14034,7 +14034,7 @@ Jupyter kernels such as IJulia and IRKernel.")
python-jupyter-core python-pygments python-pyqt python-pyzmq
python-qtpy python-traitlets))
(native-inputs
- (list python-flaky python-pytest))
+ (list python-flaky python-pytest python-pytest-qt))
(home-page "https://jupyter.org")
(synopsis "Jupyter Qt console")
(description "This package provides a Qt-based console for Jupyter with