summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-24 00:30:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:11 -0400
commitb3a77978c91e04c8486ceb85e11315de721da8a8 (patch)
tree4b1e927b07290bdbfabb870da08ea28cff3a4c64
parent9fd911eb9b6e55e5586314605f0074f95f190466 (diff)
downloadguix-patches-b3a77978c91e04c8486ceb85e11315de721da8a8.tar
guix-patches-b3a77978c91e04c8486ceb85e11315de721da8a8.tar.gz
gnu: Add texlive-underscore.
* gnu/packages/tex.scm (texlive-underscore): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9f8fdbafdc..818316a4e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -664,6 +664,26 @@ executables. It is maintained as a part of TeX Live.")))
documentation from TeX files. It is part of the LaTeX base.")
(license license:lppl1.3+)))
+(define-public texlive-underscore
+ (package
+ (inherit (simple-texlive-package
+ "texlive-underscore"
+ (list "/doc/latex/underscore/"
+ "/tex/latex/underscore/")
+ (base32
+ "0slxsxc9azmv3gsm55jkhkv8a06wafankp55hhsdd6k4prp8szrb")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/underscore")
+ (synopsis "Control the behaviour of @samp{_} in text")
+ (description "This package causes @code{\\_} in text mode (i.e.,
+@code{\\textunderscore}) to print an underscore so that hyphenation of words
+either side of it is not affected; a package option controls whether an actual
+hyphenation point appears after the underscore, or merely a break point. The
+package also arranges that, while in text, @samp{_} itself behaves as
+@code{\\textunderscore} (the behaviour of @samp{_} in maths mode is not
+affected).")
+ (license license:lppl1.2+)))
+
(define-public texlive-unicode-data
(package
(inherit (simple-texlive-package