summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 08:46:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:33 -0400
commitb391578a2447e677528d6684f424ab798b885dc0 (patch)
tree07ac677a4c28ef115742def03dfd42ea4f79e8b9
parent9175b8d6ba7c5939bfee3b76904ee8627f38f949 (diff)
downloadguix-patches-b391578a2447e677528d6684f424ab798b885dc0.tar
guix-patches-b391578a2447e677528d6684f424ab798b885dc0.tar.gz
gnu: python-factory-boy: Update to 3.2.1.
* gnu/packages/python-xyz.scm (python-factory-boy): Update to 3.2.1. [propagated-inputs]: Use new style. [description]: Fix indentation and remove blank lines.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ebdd81f8e..176fa7ec28 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20004,30 +20004,26 @@ point is the point of maximum curvature.")
(define-public python-factory-boy
(package
(name "python-factory-boy")
- (version "2.8.1")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "factory_boy" version))
(sha256
- (base32 "1fvin6san5xsjh2c4y18caj2lnmwxlylyqm8mh1yc6rp38wlwr56"))))
+ (base32 "0pm5lbvnwm0kg5i6z611rg907yw1gy551f2advmpaz041ixjg3d9"))))
(build-system python-build-system)
(arguments
;; Tests are not included in the tarball.
`(#:tests? #f))
- (propagated-inputs
- `(("faker" ,python-faker)))
+ (propagated-inputs (list python-faker))
(home-page "https://github.com/benhoyt/scandir")
(synopsis "Versatile test fixtures replacement")
- (description
- "Factory_boy is a fixtures replacement based on thoughtbot’s factory_girl.
-
- As a fixtures replacement tool, it aims to replace static, hard to maintain
- fixtures with easy-to-use factories for complex object.
-
- Instead of building an exhaustive test setup with every possible combination
- of corner cases, factory_boy allows you to use objects customized for the
- current test, while only declaring the test-specific fields")
+ (description "Factory_boy is a fixtures replacement based on thoughtbot’s
+factory_girl. As a fixtures replacement tool, it aims to replace static, hard
+to maintain fixtures with easy-to-use factories for complex object. Instead
+of building an exhaustive test setup with every possible combination of corner
+cases, factory_boy allows you to use objects customized for the current test,
+while only declaring the test-specific fields.")
(license license:expat)))
(define-public python-translate-toolkit