summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 16:17:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:01 -0400
commitabca2b804740ec28d56f4ef291b07dfe913b5361 (patch)
treeb8d535664a8d98ae5bf87f87f1ba0b63c342b81c
parentd45727f4e4be401cbed6c49614e242ffc0a5c581 (diff)
downloadguix-patches-abca2b804740ec28d56f4ef291b07dfe913b5361.tar
guix-patches-abca2b804740ec28d56f4ef291b07dfe913b5361.tar.gz
gnu: python-multipart: Fix build with PyYAML 6.
* gnu/packages/python-xyz.scm (python-multipart) [phases]{patch-test-suite}: Substitute yaml.load for yaml.safe_load.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 97eb3651a5..e86be67ddb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30677,6 +30677,10 @@ writing STL files. It supports both the text and binary forms of STL.")
;; There is a bug in the test_suit specification.
(add-after 'unpack 'patch-test-suite
(lambda _
+ ;; Make compatible with PyYAML 6.
+ (substitute* "multipart/tests/test_multipart.py"
+ (("yaml.load")
+ "yaml.safe_load"))
(substitute* "setup.py"
(("test_suite = 'multipart.tests.suite'")
"test_suite = 'multipart.tests.test_multipart.suite'"))