summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-12 09:45:00 +0100
committerOleg Pykhalov <go.wigust@gmail.com>2019-03-12 21:56:09 +0300
commit94a33ab899cddeda3b577cc968cd905623a692f1 (patch)
treefdc2fd6cadb9e9d6c0f629b18fb5858022b842b9
parent61ce2e77ff77ab4ad260343e77989201a6826482 (diff)
downloadguix-patches-94a33ab899cddeda3b577cc968cd905623a692f1.tar
guix-patches-94a33ab899cddeda3b577cc968cd905623a692f1.tar.gz
gnu: Add emacs-eshell-bookmark.
* gnu/packages/emacs-xyz.scm (emacs-eshell-bookmark): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 064b8cb054..d3b2fc8ec6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11176,6 +11176,29 @@ systems.")
filters, highlighting of regexp group levels, and more.")
(license license:gpl2+))))
+(define-public emacs-eshell-bookmark
+ (package
+ (name "emacs-eshell-bookmark")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Fuco1/eshell-bookmark")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14dmsnixf9vqdhsixw693sml0fn80zcf0b37z049fb40cmppqxdw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fuco1/eshell-bookmark")
+ (synopsis "Provide @file{bookmark.el} integration for @code{eshell}")
+ (description
+ "This package allows for bookmarking @code{eshell} buffers. Upon
+visiting the bookmark, a new @code{eshell} session will be opened in the
+appropriate directory if no @code{eshell} session is active.")
+ (license license:gpl3+)))
+
(define-public emacs-esh-autosuggest
(package
(name "emacs-esh-autosuggest")