summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-21 21:49:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:08 -0400
commit80ec843bf4e5a3d458e5aa4147f732353a8d2e23 (patch)
treef2604a9dbc1d3b5a4ecaf6c384aa636db339cbb0
parent9812a44f8654176c51ba1af18b0b38d91f812443 (diff)
downloadguix-patches-80ec843bf4e5a3d458e5aa4147f732353a8d2e23.tar
guix-patches-80ec843bf4e5a3d458e5aa4147f732353a8d2e23.tar.gz
gnu: python-sphinx-click: Update to 4.0.3 and enable tests.
* gnu/packages/sphinx.scm (python-sphinx-click): Update to 4.0.3. [arguments]: Delete field. [native-inputs]: Delete python-coverage. Add python-pytest and python-wheel. Move python-click, python-docutils and python-sphinx to... [propagated-inputs]: ... here.
-rw-r--r--gnu/packages/sphinx.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 5788bb7870..739d32398c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -242,23 +242,23 @@ Apple help books.")
(define-public python-sphinx-click
(package
(name "python-sphinx-click")
- (version "3.0.1")
+ (version "4.0.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sphinx-click" version))
(sha256
(base32
- "118ppsymp1p2gn8v7mifika817qx6v07mja7kxizq9cg7dpw894v"))))
+ "1nqy3b7wr64rbmdp7kpi723az53a89y6250h46i505g1rw0czam1"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f)) ;requires python-coverage<5.0
- (native-inputs
- (list python-click
- python-coverage
- python-docutils
- python-pbr
- python-sphinx))
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests")))))))
+ (native-inputs (list python-pbr python-pytest python-wheel))
+ (propagated-inputs (list python-click python-docutils python-sphinx))
(home-page "https://github.com/click-contrib/sphinx-click")
(synopsis "Sphinx extension that documents click applications")
(description "This package provide sphinx extension that automatically