summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 01:47:20 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:07 -0400
commit7d882da0ebdb64b7d0dbdfe964bc75d3274a3265 (patch)
treeafc1b6479b03e745f7ccdb3abae1b7223b1566e6
parentdff469209e14b867b1f3f6e946526b4654cc4d08 (diff)
downloadguix-patches-7d882da0ebdb64b7d0dbdfe964bc75d3274a3265.tar
guix-patches-7d882da0ebdb64b7d0dbdfe964bc75d3274a3265.tar.gz
gnu: python-flask-login: Update to 0.6.0.
* gnu/packages/python-web.scm (python-flask-login): Update to 0.6.0. [arguments]: New field. [native-inputs]: Remove python-coverage, python-pycodestyle and python-pyflakes.
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f98f824daa..094ec10e4b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3837,7 +3837,7 @@ on the command line.")
(define-public python-flask-login
(package
(name "python-flask-login")
- (version "0.5.0")
+ (version "0.6.0")
(source
(origin
(method git-fetch)
@@ -3846,17 +3846,21 @@ on the command line.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "11ac924w0y4m0kf3mxnxdlidy88jfa7njw5yyrq16dvnx4iwd8gg"))))
+ (base32 "12yw01ccgjn9c88cbkrd6k1ykjxd8fxip2b1isvxjirphnlqhn9g"))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-c" "/dev/null")))))))
(propagated-inputs
(list python-flask))
(native-inputs
;; For tests.
(list python-blinker
- python-coverage
python-mock
- python-pycodestyle
- python-pyflakes
python-pytest
python-semantic-version
python-werkzeug))