summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-05 01:58:29 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:54 +0100
commit589b9d6f29aeb9349311c416004cca3f517f7db2 (patch)
tree13a605f6811c63ac70cc1037fe6ea9d8b08548ef
parent7e9720eca429e150e199a9f3ccb1f9d95ad76aeb (diff)
downloadguix-patches-589b9d6f29aeb9349311c416004cca3f517f7db2.tar
guix-patches-589b9d6f29aeb9349311c416004cca3f517f7db2.tar.gz
gnu: python-aws-sam-translator: Update to 1.40.0.
* gnu/packages/python-web.scm (python-aws-sam-translator): Update to 1.40.0. [arguments]<#:phases>: Don't return #t. [home-page]: Follow redirect. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d4a785b2fc..becd1cfdbf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -399,13 +399,13 @@ WSGI. This package includes libraries for implementing ASGI servers.")
(define-public python-aws-sam-translator
(package
(name "python-aws-sam-translator")
- (version "1.38.0")
+ (version "1.40.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "aws-sam-translator" version))
(sha256
(base32
- "1djwlsjpbh13m4biglimrm9lq7hmla0k29giay7k3cjsrylxvjhf"))))
+ "1hq5ggbzcq4k3ks439hki493w4sasgaxns6j5x57xsj822acalmf"))))
(build-system python-build-system)
(arguments
`(;; XXX: Tests are not distributed with the PyPI archive, and would
@@ -418,13 +418,12 @@ WSGI. This package includes libraries for implementing ASGI servers.")
;; of dependencies, when it works fine with others.
(substitute* "requirements/base.txt"
(("(.*)(~=[0-9\\.]+)" all package version)
- package))
- #t)))))
+ package)))))))
(propagated-inputs
`(("python-boto3" ,python-boto3)
("python-jsonschema" ,python-jsonschema)
("python-six" ,python-six)))
- (home-page "https://github.com/awslabs/serverless-application-model")
+ (home-page "https://github.com/aws/serverless-application-model")
(synopsis "Transform AWS SAM templates into AWS CloudFormation templates")
(description
"AWS SAM Translator is a library that transform @dfn{Serverless Application