summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-21 23:20:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:09 -0400
commit4d62953573ecf8a1e5616a4a7c1577d91ad9f57a (patch)
tree601bdafe00903bcb6e839039efd73df81b00a39b
parent50b620f119e3aea2876f4b8580a49de059fc038b (diff)
downloadguix-patches-4d62953573ecf8a1e5616a4a7c1577d91ad9f57a.tar
guix-patches-4d62953573ecf8a1e5616a4a7c1577d91ad9f57a.tar.gz
gnu: Add python-nptyping.
* gnu/packages/python-check.scm (python-nptyping): New variable.
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 8cabd05dd5..a1601d6656 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1811,6 +1811,40 @@ them using any Python VM with basically no runtime overhead.")
(delete 'ensure-no-mtimes-pre-1980))))
(native-inputs '()))))
+(define-public python-nptyping
+ (package
+ (name "python-nptyping")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch) ;pypi only contains a binary wheel
+ (uri (git-reference
+ (url "https://github.com/ramonhagenaars/nptyping")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0839mcrv5jljq9k9124ssnl1hc1inbxwlwjk72imabsbqssjy9rb"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-source-date-epoch
+ (lambda _
+ ;; Otherwise the wheel building test would fail with "ZIP does
+ ;; not support timestamps before 1980".
+ (setenv "SOURCE_DATE_EPOCH" "315532800"))))))
+ (native-inputs
+ (list python-beartype
+ python-mypy
+ python-typeguard
+ python-wheel))
+ (propagated-inputs (list python-numpy python-typing-extensions))
+ (home-page "https://github.com/ramonhagenaars/nptyping")
+ (synopsis "Type hints for Numpy")
+ (description "This package provides extensive dynamic type checks for
+dtypes and shapes of arrays for NumPy, extending @code{numpy.typing}.")
+ (license license:expat)))
+
(define-public python-pylama
(package
(name "python-pylama")