summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 14:03:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:07 -0400
commit418630a63c26bf683bb215fe2f655485f07020ea (patch)
tree72cbf2750997da275d2cd2f5845a4e6c02d8ccc1
parentab36b88b1a67059a9ea5a3c1c6b5db6563c962cc (diff)
downloadguix-patches-418630a63c26bf683bb215fe2f655485f07020ea.tar
guix-patches-418630a63c26bf683bb215fe2f655485f07020ea.tar.gz
gnu: dynaconf: Fix build following python-click upgrade.
* gnu/packages/python-xyz.scm (dynaconf) [phases]{patch-for-click-8}: New phase. {check}: Remove extraneous setenv call. [native-inputs]: Use the regular python-pytest variable.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d12f28850..8b55e67ca9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30183,12 +30183,14 @@ Python @code{set} interface.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-click-8
+ (lambda _
+ (substitute* "dynaconf/cli.py"
+ (("click.get_os_args\\()") ;deprecated from Click 8.1+
+ "sys.argv[1:]"))))
(replace 'check
(lambda* (#:key tests? outputs #:allow-other-keys)
(when tests?
- (setenv "PATH"
- (string-append (assoc-ref outputs "out") "/bin:"
- (getenv "PATH")))
;; These tests depend on hvac and a live Vault process.
(delete-file "tests/test_vault.py")
(invoke "make" "test_only")))))))
@@ -30196,7 +30198,7 @@ Python @code{set} interface.")
(list python-click python-configobj python-dotenv-0.13.0
python-ruamel.yaml python-toml))
(native-inputs
- (list python-django python-flask python-pytest-6 python-pytest-cov
+ (list python-django python-flask python-pytest python-pytest-cov
python-pytest-mock))
(home-page "https://www.dynaconf.com/")
(synopsis "The dynamic configurator for your Python project")