summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 12:52:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:58 -0400
commit1f88242992346d4e09d959abebb3fc34933bc6b5 (patch)
tree634261acc4394d6e1eed3ee138751971a8126428
parent046e5f0d041c9122c0881e8e5d1b5927aa44e9e5 (diff)
downloadguix-patches-1f88242992346d4e09d959abebb3fc34933bc6b5.tar
guix-patches-1f88242992346d4e09d959abebb3fc34933bc6b5.tar.gz
gnu: python-parse-type: Update to 0.6.0, fixing build.
* gnu/packages/python-xyz.scm (python-parse-type): Update to 0.6.0. [arguments]: New field. [native-inputs]: Remove python-pytest-runner and python-setuptools.
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2713caa0f..d47d9507ba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2968,21 +2968,24 @@ backported for previous versions of Python from 2.4 to 3.3.")
(define-public python-parse-type
(package
(name "python-parse-type")
- (version "0.5.2")
+ (version "0.6.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "parse_type" version))
- (sha256
- (base32
- "02wclgiqky06y36b3q07b7ngpks5j0gmgl6n71ac2j2hscc0nsbz"))))
+ (method url-fetch)
+ (uri (pypi-uri "parse_type" version))
+ (sha256
+ (base32
+ "07smqnzc9km7sbvxfyx4gdm9njrx58x8grdw6gs4gva81rk3rd10"))))
(build-system python-build-system)
- (propagated-inputs
- (list python-six python-parse))
- (native-inputs
- ;; Use setuptools < 58 to work around
- ;; https://github.com/jenisys/parse_type/issues/17
- (list python-pytest python-pytest-runner python-setuptools))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-c" "/dev/null")))))))
+ (propagated-inputs (list python-six python-parse))
+ (native-inputs (list python-pytest))
(home-page "https://github.com/jenisys/parse_type")
(synopsis "Extended parse module")
(description