summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-22 21:55:47 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:11 -0400
commit09fccde9c04769ecf01bc5c6a22aadc9704369e5 (patch)
tree8ac453360d252d893fc22e675fad845ac89c6774
parentdfe81d0f812e012cb0cb7d6c89f8aea03b733038 (diff)
downloadguix-patches-09fccde9c04769ecf01bc5c6a22aadc9704369e5.tar
guix-patches-09fccde9c04769ecf01bc5c6a22aadc9704369e5.tar.gz
gnu: python-pudb: Update to 2022.1.1 and rename from pudb.
Renaming rationale: pudb can also be used as a Python library (like pdb). * gnu/packages/python-xyz.scm (python-pudb): Update to 2022.1.1. [phases]{check}: Remove obsolete 'add-installed-pythonpath' call. Invoke pytest verbosely. [native-inputs]: Remove python-numpy. [propagated-inputs]: Apply guix style. (pudb): Define as a deprecated alias to python-pudb.
-rw-r--r--gnu/packages/python-xyz.scm46
1 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e99587cf67..771b00e047 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30228,32 +30228,29 @@ development, testing, production]};
@end itemize")
(license license:expat)))
-(define-public pudb
+(define-public python-pudb
(package
- (name "pudb")
- (version "2021.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pudb" version))
- (sha256
- (base32 "0p16pvzfa3w02ybg3n0iy5rs23z4rz4a42lb8wh3mcq62y9ik2w7"))))
+ (name "python-pudb")
+ (version "2022.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pudb" version))
+ (sha256
+ (base32
+ "0gq82hwnibby9qdyv7ri11phvg94nby4jb0w9h3jk79w89kdsfyv"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-read-only-home
- (lambda _
- (setenv "HOME" "/tmp")))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest")))))))
- (native-inputs
- (list python-numpy python-pytest python-pytest-mock))
- (propagated-inputs
- (list python-jedi python-pygments python-urwid python-urwid-readline))
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'check 'fix-read-only-home
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest python-pytest-mock))
+ (propagated-inputs (list python-jedi python-pygments python-urwid
+ python-urwid-readline))
(home-page "https://documen.tician.de/pudb/")
(synopsis "Console-based Python debugger")
(description
@@ -30262,6 +30259,9 @@ all the niceties of modern GUI-based debuggers in a more lightweight and
keyboard-friendly package.")
(license license:expat)))
+(define-public pudb
+ (deprecated-package "pudb" python-pudb))
+
(define-public python-iwlib
(package
(name "python-iwlib")