summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 17:43:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:55 -0400
commit06b0512260b366513c7f3c3e8f9a6b298da968b7 (patch)
tree49d9281c8d6d06a6f6a0633b8b180b922a944d79
parent1d1f44b7099a745028a4d99d623c709ab004524b (diff)
downloadguix-patches-06b0512260b366513c7f3c3e8f9a6b298da968b7.tar
guix-patches-06b0512260b366513c7f3c3e8f9a6b298da968b7.tar.gz
gnu: python-pynndescent: Update to 0.5.6.
* gnu/packages/machine-learning.scm (python-pynndescent): Update to 0.5.6. [phases]{check}: Skip the test_weighted_minkowski test. [native-inputs, propagated-inputs]: Re-indent.
-rw-r--r--gnu/packages/machine-learning.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index b765257d98..5f14453f01 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1210,13 +1210,13 @@ for scientific computing and data science (e.g. BLAS and OpenMP).")
(define-public python-pynndescent
(package
(name "python-pynndescent")
- (version "0.5.5")
+ (version "0.5.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pynndescent" version))
(sha256
- (base32 "10pqqqc3jkpw03cyzy04slxmpgyhqnlgbyk0c1cv7kqr5d0zhzbs"))))
+ (base32 "0p3jsdcprjfzz7qf5674dsqfpvdn6p4wgqikg7b6ki5abf433yv1"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1224,12 +1224,16 @@ for scientific computing and data science (e.g. BLAS and OpenMP).")
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest" "--pyargs" "pynndescent")))))))
- (native-inputs
- (list python-pytest))
+ (invoke "python" "-m" "pytest" "--pyargs" "pynndescent"
+ ;; wminkowski no longer exists in scipy 1.8.0 (see:
+ ;; https://github.com/lmcinnes/pynndescent/issues/177)
+ "-k" "not test_weighted_minkowski")))))))
+ (native-inputs (list python-pytest))
(propagated-inputs
- (list python-joblib python-llvmlite python-numba python-scikit-learn
+ (list python-joblib
+ python-llvmlite
+ python-numba
+ python-scikit-learn
python-scipy))
(home-page "https://github.com/lmcinnes/pynndescent")
(synopsis "Nearest neighbor descent for approximate nearest neighbors")