summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-17 05:46:38 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-19 10:48:42 +0100
commite3bba7f720d74320e24e752c9cdcb193a939480c (patch)
tree703471624333d868a114d3359cdb5e7fb768f31b
parent4cc345faf950fe47afd38ce9657ce8d5d69acaf9 (diff)
downloadguix-patches-e3bba7f720d74320e24e752c9cdcb193a939480c.tar
guix-patches-e3bba7f720d74320e24e752c9cdcb193a939480c.tar.gz
gnu: Add cl-terminal-keypress.
* gnu/packages/lisp-xyz.scm (cl-terminal-keypress, ecl-terminal-keypress, sbcl-terminal-keypress): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 128aefb979..541af9b7a8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18953,6 +18953,48 @@ Lisp.")
(define-public ecl-trivial-raw-io
(sbcl-package->ecl-package sbcl-trivial-raw-io))
+(define-public sbcl-terminal-keypress
+ (let ((commit "2ef48c045aa627229764b2aa393a83d392d93d08")
+ (revision "1"))
+ (package
+ (name "sbcl-terminal-keypress")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eudoxia0/terminal-keypress")
+ (commit commit)))
+ (file-name (git-file-name "cl-terminal-keypress" version))
+ (sha256
+ (base32 "11c4krpq5x55qkchx6ykcnb455ssb4r3jjywx3c3irfrkj733ybp"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("trivial-raw-io" ,sbcl-trivial-raw-io)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (home-page "https://github.com/eudoxia0/terminal-keypress")
+ (synopsis "Read keyboard events in the terminal from Common Lisp")
+ (description
+ "This is a library for reading semi-raw user input from terminals.
+Semi-raw as in, we can't detect if the user pressed the @code{Control} key
+alone, and the function keys are a mystery. What is supported, however, is:
+
+@itemize
+@item Regular characters
+@item Control+[key]
+@item Alt+[key]
+@item Control+Alt+[key]
+@end itemize")
+ (license license:expat))))
+
+(define-public cl-terminal-keypress
+ (sbcl-package->cl-source-package sbcl-terminal-keypress))
+
+(define-public ecl-terminal-keypress
+ (sbcl-package->ecl-package sbcl-terminal-keypress))
+
(define-public sbcl-periodic-table
(package
(name "sbcl-periodic-table")