summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:00 +0200
commit6f4ceb544952ceb1c34fcd754547003b7dd0c16f (patch)
tree5187f1f40dc202cac8e5421c3ff5a8f52360c3f4
parent601d95206decdc85186dd0cfba4bd3b70658c7e4 (diff)
downloadguix-patches-6f4ceb544952ceb1c34fcd754547003b7dd0c16f.tar
guix-patches-6f4ceb544952ceb1c34fcd754547003b7dd0c16f.tar.gz
gnu: libscrypt: Use G-expressions.
* gnu/packages/crypto.scm (libscrypt)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/crypto.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 0cef58259e..f938d3c115 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -593,17 +593,16 @@ attacks than alternative functions such as @code{PBKDF2} or @code{bcrypt}.")
(build-system gnu-build-system)
(outputs (list "out" "static"))
(arguments
- `(#:make-flags (list (string-append "PREFIX=" %output)
- ,(string-append "CC=" (cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-after 'install 'install:static
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
- (install-file "libscrypt.a" lib)
- #t))))))
+ (list #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'install 'install:static
+ (lambda _
+ (install-file "libscrypt.a"
+ (string-append #$output:static "/lib")))))))
(home-page "https://lolware.net/libscrypt.html")
(synopsis "Password hashing library")
(description "@code{libscrypt} implements @code{scrypt} key derivation