summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-11 11:26:37 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-11 11:28:21 +0300
commitd47b7bbfc818e16ab9899756f3a27f89834d4021 (patch)
tree49c7c32cc7e78f929639659d6768388c528908f9
parent9dd784bacee8f3d3aed6e25520a4fd049be0597d (diff)
downloadguix-patches-d47b7bbfc818e16ab9899756f3a27f89834d4021.tar
guix-patches-d47b7bbfc818e16ab9899756f3a27f89834d4021.tar.gz
gnu: rust-nalgebra-macros-0.1: Move code changes to snippet.
* gnu/packages/crates-io.scm (rust-nalgebra-macros-0.1)[arguments]: Move code relaxing version requirements ... [source]: ... to a snippet.
-rw-r--r--gnu/packages/crates-io.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bfd8e42b7d..c595e920aa 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35915,18 +35915,16 @@ statically-sized or dynamically-sized matrices.")
(uri (crate-uri "nalgebra-macros" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "063jvvvlwmzzxfr4wyiil2cn1yqj3arvghwsr2nk4ilv2jwc1z01"))))
+ (base32 "063jvvvlwmzzxfr4wyiil2cn1yqj3arvghwsr2nk4ilv2jwc1z01"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Cargo.toml"
+ ;; The resolver feature is not supported by our versions of Cargo.
+ (("resolver = \"2\".*") ""))))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'patch-Cargo.toml
- (lambda _
- (substitute* '("Cargo.toml"
- "guix-vendor/rust-nalgebra-macros-0.1.0.tar.gz/Cargo.toml")
- ;; The resolver feature is not supported by this version of Cargo.
- (("resolver = \"2\".*") "")))))
#:cargo-inputs
(("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)