summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-04-26 18:16:33 +0530
committerEfraim Flashner <efraim@flashner.co.il>2022-05-09 11:15:12 +0300
commitcbda00c499385d5d0c7997bf2bf209c9d68b9df5 (patch)
tree8726162fadf5a48ec509bbc6073555f6ccb67d69
parenta99054795240cb7c17754816127a86d764fe76db (diff)
downloadguix-patches-cbda00c499385d5d0c7997bf2bf209c9d68b9df5.tar
guix-patches-cbda00c499385d5d0c7997bf2bf209c9d68b9df5.tar.gz
gnu: tabixpp: Use build tools specific to the target.
* gnu/packages/bioinformatics.scm (tabixpp)[arguments]: Set CC and CXX in #:make-flags. In the build-libraries phase, use cxx-for-target instead of g++ and ar-for-target instead of ar. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 35e575d17c..7dbc2683e4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14298,7 +14298,9 @@ mutations from scRNA-Seq data.")
(inputs
(list htslib zlib))
(arguments
- (list #:make-flags #~(list "HTS_HEADERS="
+ (list #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "CXX=" #$(cxx-for-target))
+ "HTS_HEADERS="
(string-append "HTS_LIB="
(search-input-file %build-inputs
"/lib/libhts.a"))
@@ -14310,8 +14312,9 @@ mutations from scRNA-Seq data.")
;; Build shared and static libraries.
(add-after 'build 'build-libraries
(lambda* (#:key inputs #:allow-other-keys)
- (invoke "g++" "-shared" "-o" "libtabixpp.so" "tabix.o" "-lhts")
- (invoke "ar" "rcs" "libtabixpp.a" "tabix.o")))
+ (invoke #$(cxx-for-target)
+ "-shared" "-o" "libtabixpp.so" "tabix.o" "-lhts")
+ (invoke #$(ar-for-target) "rcs" "libtabixpp.a" "tabix.o")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))