summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-04-14 12:30:30 +0530
committerLudovic Courtès <ludo@gnu.org>2022-05-09 00:07:33 +0200
commitcb9db2b0ea67d1c3733310203a034399e6c841b1 (patch)
treeff4c6da9ceced3fe63175983670fa85533514486
parent4f3fd912a7bfcc8dd8bbcdfa1df7b7b58dc05746 (diff)
downloadguix-patches-cb9db2b0ea67d1c3733310203a034399e6c841b1.tar
guix-patches-cb9db2b0ea67d1c3733310203a034399e6c841b1.tar.gz
gnu: Add emacs-flymake-proselint.
* gnu/packages/emacs-xyz.scm (emacs-flymake-proselint): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b139b661cb..2d1e83b021 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6134,6 +6134,41 @@ the current Cargo project.")
files which are intended to be packages.")
(license license:gpl3+)))
+(define-public emacs-flymake-proselint
+ (let ((commit "6a99865c7ac6474b8c5d1f9a1ae2384667f06d36")
+ (revision "0"))
+ (package
+ (name "emacs-flymake-proselint")
+ (version (git-version "0.2.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~manuel-uberti/flycheck-proselint")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "028ilp9h22rlawlh5ydiykvi8pryyknwi019sjyxkk2h0fza9jan"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "flymake-proselint.el"
+ (("\"proselint\"")
+ (string-append
+ "\"" (search-input-file inputs "/bin/proselint") "\""))))))))
+ (propagated-inputs
+ (list emacs-flycheck))
+ (inputs
+ (list python-proselint))
+ (home-page "https://git.sr.ht/~manuel-uberti/flycheck-proselint")
+ (synopsis "Flymake backend for @code{proselint}")
+ (description "This package adds support for @code{proselint} in Flymake.")
+ (license license:gpl3+))))
+
(define-public emacs-elisp-demos
(package
(name "emacs-elisp-demos")