summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-05 12:27:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-06 10:15:00 +0200
commitb95e3dc17cc8f4ba4f7796a12c34837dd4af164b (patch)
tree8a30a1861c907c1788e4b75746746e1ea51a092f
parent312879fddcf0713c0f1dafcc6faa089edbbb6e04 (diff)
downloadguix-patches-b95e3dc17cc8f4ba4f7796a12c34837dd4af164b.tar
guix-patches-b95e3dc17cc8f4ba4f7796a12c34837dd4af164b.tar.gz
gnu: python-multipart: Fix test failure due to PyYAML 6.
* gnu/packages/python-xyz.scm (python-multipart)[arguments]: Patch instance of yaml.load.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 82d297af3b..a37dc5e9e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29393,7 +29393,11 @@ writing STL files. It supports both the text and binary forms of STL.")
(lambda _
(substitute* "setup.py"
(("test_suite = 'multipart.tests.suite'")
- "test_suite = 'multipart.tests.test_multipart.suite'")))))))
+ "test_suite = 'multipart.tests.test_multipart.suite'"))
+ ;; Needed by PyYAML 6.0.
+ (substitute* "multipart/tests/test_multipart.py"
+ (("yaml_data = yaml.load\\(f\\)")
+ "yaml_data = yaml.load(f, Loader=yaml.SafeLoader)")))))))
(home-page "https://github.com/andrew-d/python-multipart")
(synopsis "Streaming multipart parser for Python")
(description