summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-05-10 08:05:22 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-05-10 08:05:22 -0400
commitdde2e36394a07a863339950e18f384f4f2ce69fd (patch)
tree454682f7725c3b242acab1966ff2c35f8a42e026
parentad2f8ee1b233adfca8f97350598b7751480654c9 (diff)
downloadguix-patches-dde2e36394a07a863339950e18f384f4f2ce69fd.tar
guix-patches-dde2e36394a07a863339950e18f384f4f2ce69fd.tar.gz
gnu: Add ruby-lazy-object.
* gnu/packages/ruby.scm (ruby-lazy-object): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9b3a61041a..ff05f63662 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12401,3 +12401,22 @@ multiformats.")
implementation for Ruby. A multihash is a digest with an embedded hash function
code")
(license license:expat)))
+
+(define-public ruby-lazy-object
+ (package
+ (name "ruby-lazy-object")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "lazy_object" version))
+ (sha256
+ (base32 "08px15lahc28ik9smvw1hgamf792gd6gq0s4k94yq1h7jq25wjn8"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (home-page "https://github.com/HornsAndHooves/lazy_object")
+ (synopsis "Object wrapper that forwards all calls to the reference object")
+ (description "LazyObject is an object wrapper that forwards all calls to the
+reference object. This object is not created until the first method dispatch.")
+ (license license:expat)))