summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-01 02:00:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-01 02:00:06 +0200
commitcb8e483c78eed9693c2b68ce490742e58c1efc13 (patch)
tree7c7c6abab031feb7b88a752ca309f807a8ea510a
parent9b66f0a74dd515e73d55dff8b807fdf569e67c9d (diff)
downloadguix-patches-cb8e483c78eed9693c2b68ce490742e58c1efc13.tar
guix-patches-cb8e483c78eed9693c2b68ce490742e58c1efc13.tar.gz
gnu: butt: Use new input style where convenient.
* gnu/packages/audio.scm (butt)[inputs]: Use new style.
-rw-r--r--gnu/packages/audio.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ccae818dd4..b75a00d89f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5475,32 +5475,32 @@ while still staying in time.")
(doc (string-append out "/share/doc/" ,name "-" ,version)))
(install-file "README" doc)
(copy-file manual (string-append doc "/butt-manual.pdf"))))))))
- (inputs
- `(("dbus" ,dbus)
- ("flac" ,flac)
- ("fltk" ,fltk)
- ("lame" ,lame)
- ("libfdk" ,libfdk)
- ("libsamplerate" ,libsamplerate)
- ("libvorbis" ,libvorbis)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxfixes" ,libxfixes)
- ("libxft" ,libxft)
- ("libxrender" ,libxrender)
- ("ogg" ,libogg)
- ("openssl" ,openssl)
- ("opus" ,opus)
- ("portaudio" ,portaudio)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("manual" ,(origin
- (method url-fetch)
- (uri (string-append "https://danielnoethen.de/butt/butt-"
- version "_manual.pdf"))
- (sha256
- (base32
- "0kadqzzbk25n0aqxgbqhg4mq4hsbjq44phzcx5qj1b8847yzz8si"))))))
+ ("manual"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://danielnoethen.de/butt/butt-"
+ version "_manual.pdf"))
+ (sha256
+ (base32 "0kadqzzbk25n0aqxgbqhg4mq4hsbjq44phzcx5qj1b8847yzz8si"))))))
+ (inputs
+ (list dbus
+ flac
+ fltk
+ lame
+ libfdk
+ libsamplerate
+ libvorbis
+ libx11
+ libxext
+ libxfixes
+ libxft
+ libxrender
+ libogg
+ openssl
+ opus
+ portaudio))
(home-page "https://danielnoethen.de/butt/")
(synopsis "Audio streaming tool")
(description "Butt is a tool to stream audio to a ShoutCast or