summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-09 11:56:59 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-09 12:26:45 +0200
commitbb8c5f520588f43a63e3f58bf12b631f9001e7ef (patch)
tree4b990d1254348f410b27c206c7ba6fb20427d1ba
parent4d1a88312cbebb10d47905d6d023953ac85bcd04 (diff)
downloadguix-patches-bb8c5f520588f43a63e3f58bf12b631f9001e7ef.tar
guix-patches-bb8c5f520588f43a63e3f58bf12b631f9001e7ef.tar.gz
gnu: valgrind: Remove input labels.
* gnu/packages/valgrind.scm (valgrind/interactive)[inputs]: Remove labels. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/valgrind.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 2a6e63a410..63524d59e9 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -111,8 +111,7 @@ also use Valgrind to build new tools.")
"valgrind-fix-default-debuginfo-path.patch"))))
(inputs
;; GDB is needed to provide a sane default for `--db-command'.
- `(("gdb" ,gdb)
- ("glibc:debug" ,(canonical-package glibc) "debug")))
+ (list gdb `(,(canonical-package glibc) "debug")))
(arguments
(substitute-keyword-arguments (package-arguments valgrind)
((#:phases phases #~%standard-phases)
@@ -126,7 +125,7 @@ also use Valgrind to build new tools.")
;; TODO: Remove on the next rebuild cycle, when libc is not
;; longer fully stripped.
(define libc-debug
- (string-append (assoc-ref inputs "glibc:debug")
+ (string-append (ungexp (this-package-input "glibc") "debug")
"/lib/debug"))
(substitute* '("coregrind/m_debuginfo/readelf.c"