summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-01 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-01 02:00:00 +0200
commit755e702db7bcd5eed241b5e26072640150745564 (patch)
treed22ed9b847c8e724ca057a91a26fff1bd1a3e432
parent769202ecf81e7a0cb5810f929a1105304f15f5b4 (diff)
downloadguix-patches-755e702db7bcd5eed241b5e26072640150745564.tar
guix-patches-755e702db7bcd5eed241b5e26072640150745564.tar.gz
gnu: nnn: Use G-expressions.
* gnu/packages/admin.scm (nnn)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/admin.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e9c9ed28ed..1b01f2fe63 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3917,16 +3917,15 @@ information tool.")
(native-inputs
(list pkg-config))
(arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)) ; no configure script
- #:make-flags
- (list
- (string-append "PREFIX="
- (assoc-ref %outputs "out"))
- (string-append "CC=" ,(cc-for-target))
- (string-append "PKG_CONFIG=" ,(pkg-config-for-target)))))
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list
+ (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PKG_CONFIG=" #$(pkg-config-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/jarun/nnn")
(synopsis "Terminal file browser")
(description