summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-09 11:28:00 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-09 12:26:44 +0200
commit4668454f644705d4aa9c8e232ec23a3da9db7704 (patch)
treedd16e9ab54872c3a9d3020232f200f4143a7c578
parent9f9c2f200b6bb25486f6739dba08a818740e6a80 (diff)
downloadguix-patches-4668454f644705d4aa9c8e232ec23a3da9db7704.tar
guix-patches-4668454f644705d4aa9c8e232ec23a3da9db7704.tar.gz
gnu: libgit@1.1: Patch time-dependent unit test.
This is a followup to e48b5484afde93294c4ed7215e88ed450842b2e5. * gnu/packages/version-control.scm (libgit2-1.1)[source]: Add "revparse.c" snippet.
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b02b6e8493..49b53789f9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -874,7 +874,14 @@ write native speed custom Git applications in any language with bindings.")
"1fjdglkh04qv3b4alg621pxa689i0wlf8m7nf2755zawjr2zhwxd"))
(patches (search-patches "libgit2-mtime-0.patch"))
(snippet '(begin
- (delete-file-recursively "deps") #t))
+ (delete-file-recursively "deps")
+
+ ;; The "refs:revparse::date" test is time-dependent: it
+ ;; assumes "HEAD@{10 years ago}" doesn't match anything,
+ ;; which is no longer true. Adjust that test.
+ (substitute* "tests/refs/revparse.c"
+ (("10 years ago")
+ "100 years ago"))))
(modules '((guix build utils)))))))
(define-public git-crypt