summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-05-10 06:20:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-05-10 06:20:54 -0400
commit3ee6cb8d54845ca94c6370e3275a30f97a1db137 (patch)
tree4ad4a6eb9d60777992f15c0e6c5a3cee06fba2d1
parentc37d14fbea86e6cfd5a883da05632ce544ba01d3 (diff)
downloadguix-patches-3ee6cb8d54845ca94c6370e3275a30f97a1db137.tar
guix-patches-3ee6cb8d54845ca94c6370e3275a30f97a1db137.tar.gz
gnu: Add ruby-countdownlatch.
* gnu/packages/ruby.scm (ruby-countdownlatch): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1e21ad1e57..29f8456c7c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12282,3 +12282,21 @@ library. It is perfect for asynchronous processes like emailing, data crunching
or social platform manipulation; and generally recommended for jobs that are
fast and non-mission critical like logs, emails, etc.")
(license license:expat)))
+
+(define-public ruby-countdownlatch
+ (package
+ (name "ruby-countdownlatch")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "countdownlatch" version))
+ (sha256
+ (base32 "1v6pbay6z07fp7yvnba1hmyacbicvmjndd8rn2h1b5rmpcb5s0j3"))))
+ (build-system ruby-build-system)
+ (home-page "https://github.com/benlangfeld/countdownlatch")
+ (synopsis "Thread synchronization aid Ruby")
+ (description "CountDownLatch is a synchronization aid that allows one or
+more threads to wait until a set of operations being performed in other threads
+completes.")
+ (license license:expat)))