summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-05-10 06:39:55 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-05-10 06:39:55 -0400
commit22b9ac3f76a3d6970decbff29a999e118c4281b0 (patch)
tree5a8de372545d6ab40d6432d669f9a0aa0af46d34
parent3ee6cb8d54845ca94c6370e3275a30f97a1db137 (diff)
downloadguix-patches-22b9ac3f76a3d6970decbff29a999e118c4281b0.tar
guix-patches-22b9ac3f76a3d6970decbff29a999e118c4281b0.tar.gz
gnu: Add ruby-value-semantics.
* gnu/packages/ruby.scm (ruby-value-semantics): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 29f8456c7c..817f9f614b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12300,3 +12300,31 @@ fast and non-mission critical like logs, emails, etc.")
more threads to wait until a set of operations being performed in other threads
completes.")
(license license:expat)))
+
+(define-public ruby-value-semantics
+ (package
+ (name "ruby-value-semantics")
+ (version "3.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "value_semantics" version))
+ (sha256
+ (base32 "1vdwai8wf6r1fkvdpyz1vzxm89q7ghjvb3pqpg2kvwibwzd99dnx"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec")))))))
+ (native-inputs
+ (list
+ ruby-rspec))
+ (home-page "https://github.com/tomdalling/value_semantics")
+ (synopsis "Ruby gem for making value classes")
+ (description "ValueSemantics generates modules that provide conventional
+value semantics for a given set of attributes. The behaviour is similar to an
+immutable Struct class, plus extensible, lightweight validation and coercion.")
+ (license license:expat)))