summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJai Vetrivelan <jaivetrivelan@gmail.com>2022-04-14 13:08:03 +0530
committerLudovic Courtès <ludo@gnu.org>2022-05-09 00:07:33 +0200
commit1140dcda5c0e667b51c51eab9109e27e5552f3dc (patch)
treed5ecd8a6185dd2fbe761792b462a18d7c35a9759
parentf9157b736bc3a38cf071a2a73699beb44f1670ae (diff)
downloadguix-patches-1140dcda5c0e667b51c51eab9109e27e5552f3dc.tar
guix-patches-1140dcda5c0e667b51c51eab9109e27e5552f3dc.tar.gz
gnu: Add emacs-logos.
* gnu/packages/emacs-xyz.scm (emacs-logos): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c1783426cc..c451172f0d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13197,6 +13197,42 @@ provides functions to convert hash tables from and to alists and plists.")
you to deal with multiple log levels.")
(license license:gpl3+)))
+(define-public emacs-logos
+ (package
+ (name "emacs-logos")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/logos")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xhnhaxmjqdv0bbh22gj9ak83hha8d59q64b6aa4rynrgcyajk45"))))
+ (native-inputs (list texinfo))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "logos.info" (string-append #$output "/share/info")))))))
+ (home-page "https://protesilaos.com/emacs/logos")
+ (synopsis "Simple focus mode for Emacs")
+ (description "This package provides a simple focus mode which can be
+applied to any buffer for reading, writing, or even doing a presentation. The
+buffer can be divided in pages using the @code{page-delimiter}, outline
+structure, or any other pattern.")
+ (license (list license:gpl3+
+ license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+
(define-public emacs-gn-mode
(package
(name "emacs-gn-mode")