summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-05-10 09:55:06 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-05-10 09:56:11 -0400
commit0f705472126f7b935e0783bcd8fec831b7a0593b (patch)
tree279a5f1c89818c6e2c5950579aecd8eabc1d6fa6
parent9b21f4b6692f846b97cdb91b1b7564716ad83b25 (diff)
downloadguix-patches-0f705472126f7b935e0783bcd8fec831b7a0593b.tar
guix-patches-0f705472126f7b935e0783bcd8fec831b7a0593b.tar.gz
gnu: Add ruby-base32.
* gnu/packages/ruby.scm (ruby-base32): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0a90398e30..15f875f976 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12488,3 +12488,23 @@ Sadayuki Furuhashi's MessagePack library.")
easier by automating repetitive work based on conventions, configuration, and
templates.")
(license license:expat)))
+
+(define-public ruby-base32
+ (package
+ (name "ruby-base32")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "base32" version))
+ (sha256
+ (base32 "1fjs0l3c5g9qxwp43kcnhc45slx29yjb6m6jxbb2x1krgjmi166b"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ (list
+ ruby-gem-release))
+ (home-page "https://github.com/stesla/base32")
+ (synopsis "Ruby extension for base32 encoding and decoding")
+ (description "Base32 is a library which provides base32 decoding and
+encoding.")
+ (license license:expat)))