summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-05-10 07:18:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-05-10 07:47:32 -0400
commit0ed219bb335b34f4ae3c1e28c923a0cfe9bd67ba (patch)
tree26a77c922d3356ac8fdc76d0509fd1c1c8e3bb10
parent0573e5962607f83b5d185ccedb6a37519e615fe5 (diff)
downloadguix-patches-0ed219bb335b34f4ae3c1e28c923a0cfe9bd67ba.tar
guix-patches-0ed219bb335b34f4ae3c1e28c923a0cfe9bd67ba.tar.gz
gnu: Add ruby-promise.
* gnu/packages/ruby.scm (ruby-promise): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 817f9f614b..23526c2243 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12328,3 +12328,37 @@ completes.")
value semantics for a given set of attributes. The behaviour is similar to an
immutable Struct class, plus extensible, lightweight validation and coercion.")
(license license:expat)))
+
+(define-public ruby-promise
+ (package
+ (name "ruby-promise")
+ (version "0.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "promise.rb" version))
+ (sha256
+ (base32 "0a819sikcqvhi8hck1y10d1nv2qkjvmmm553626fmrh51h2i089d"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'extract-gemspec 'less-strict-dependencies
+ (lambda _
+ (substitute* "Rakefile"
+ (("if Gem.ruby_version.*") "if false\n"))
+ (substitute* "spec/spec_helper.rb"
+ ((".*devtools/spec_helper.*") "\n")))))))
+ (native-inputs
+ (list
+ ruby-rspec
+ ruby-rspec-its
+ ruby-awesome-print
+ ruby-fuubar))
+ (home-page "https://github.com/lgierth/promise.rb")
+ (synopsis "Asynchronous operation library for Ruby")
+ (description "Promise is a Ruby implementation of the Promises/A+
+specification. It provides 100% mutation coverage, tested on MRI 1.9, 2.0, 2.1,
+2.2, Rubinius, and JRuby.")
+ (license license:unlicense)))