summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-04-25 04:15:57 -0400
committerMathieu Othacehe <othacehe@gnu.org>2022-05-09 09:35:29 +0200
commit09e720309ebcd1d75ef5a59737fe9876897422fe (patch)
tree0739077a2845f21f460fe15942384075a453b26e
parentcbaad2f5687f2c0583a9809bee48b7056dcf8aba (diff)
downloadguix-patches-09e720309ebcd1d75ef5a59737fe9876897422fe.tar
guix-patches-09e720309ebcd1d75ef5a59737fe9876897422fe.tar.gz
gnu: Add python-style.
* gnu/packages/python-xyz.scm (python-style): New variable. Co-authored-by: Yuchen Pei <hi@ypei.me> Co-authored-by: donotshake <dns@0cool.club> Co-authored-by: Vagrant Cascadian <vagrant@debian.org> Co-authored-by: Pranav Vats <pranavats@disroot.org> Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eea67eec46..b86774fb64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29598,6 +29598,24 @@ adapted from the @code{packaging} package.")
Python CLI apps.")
(license license:asl2.0)))
+(define-public python-style
+ (package
+ (name "python-style")
+ (version "1.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "style" version))
+ (sha256
+ (base32 "1dcfb578v9mrwh92rgms87gql0gp4vgj6l9hpgyfg0wbd3rh3bfh"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/lmittmann/style")
+ (synopsis "Terminal string styling")
+ (description
+"@code{python-style} is a simple terminal string styling package. Its API is
+a port of the chalk package for javascript.")
+ (license license:expat)))
+
(define-public python-sre-yield
(package
(name "python-sre-yield")