summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-05-01 16:54:36 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-05-01 17:05:58 +0200
commit674124b1ed01b3e10951c98ce9b2ffda62e8433f (patch)
tree626d2d5cf23659b62ddc320325bd8e53d0ba1bca
parentc34ac580dc77a92657b4a52c04a79700554a49c9 (diff)
downloadguix-patches-674124b1ed01b3e10951c98ce9b2ffda62e8433f.tar
guix-patches-674124b1ed01b3e10951c98ce9b2ffda62e8433f.tar.gz
gnu: ocaml-uuidm: Update to 0.9.8.
* gnu/packages/ocaml.scm (ocaml-uuidm): Update to 0.9.8. (ocaml4.07-uuidm): New variable.
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8295fd75a9..9d03f545e8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3893,14 +3893,14 @@ tool and piqi-ocaml.")
(define-public ocaml-uuidm
(package
(name "ocaml-uuidm")
- (version "0.9.7")
+ (version "0.9.8")
(source (origin
(method url-fetch)
(uri (string-append "http://erratique.ch/software/uuidm/"
"releases/uuidm-" version ".tbz"))
(sha256
(base32
- "1ivxb3hxn9bk62rmixx6px4fvn52s4yr1bpla7rgkcn8981v45r8"))))
+ "1cr6xlzla9fmd587lfhzac0icifspjnqi9f4cdafshj3jn85nrpw"))))
(build-system ocaml-build-system)
(arguments
`(#:build-flags
@@ -3913,6 +3913,7 @@ tool and piqi-ocaml.")
(propagated-inputs
`(("cmdliner" ,ocaml-cmdliner)
("topkg" ,ocaml-topkg)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-uuidm))))
(home-page "https://erratique.ch/software/uuidm")
(synopsis "Universally unique identifiers for OCaml")
(description "Uuidm is an OCaml module implementing 128 bits universally
@@ -3920,6 +3921,20 @@ unique identifiers (UUIDs) version 3, 5 (named based with MD5, SHA-1 hashing)
and 4 (random based) according to RFC 4122.")
(license license:isc)))
+(define-public ocaml4.07-uuidm
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-uuidm)
+ (version "0.9.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/uuidm/"
+ "releases/uuidm-" version ".tbz"))
+ (sha256
+ (base32
+ "1ivxb3hxn9bk62rmixx6px4fvn52s4yr1bpla7rgkcn8981v45r8"))))
+ (properties '()))))
+
(define-public ocaml-graph
(package
(name "ocaml-graph")