summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-05-01 08:04:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-05-01 13:14:56 +0200
commit564a31006591eacbaceb3b7ec07de4a19256c86f (patch)
tree93b9514256818fd74c67b9dc8cc0ccc6d0c9c301
parent823005c6a3f163aec24b5fb71b570a94f1fa8681 (diff)
downloadguix-patches-564a31006591eacbaceb3b7ec07de4a19256c86f.tar
guix-patches-564a31006591eacbaceb3b7ec07de4a19256c86f.tar.gz
gnu: Add ocaml-ppx-disable-unused-warnings.
* gnu/packages/ocaml.scm (ocaml-ppx-disable-unused-warnings): New variable.
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 227bdc7e1b..bb354e78b4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6637,6 +6637,30 @@ PPXs or compiler features not yet upstreamed.")
nodes for lazily rendering log messages.")
(license license:expat)))
+(define-public ocaml-ppx-disable-unused-warnings
+ (package
+ (name "ocaml-ppx-disable-unused-warnings")
+ (version "0.15.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_disable_unused_warnings")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sb5i4v7p9df2bxk66rjs30k9fqdrwsq1jgykjv6wyrx2d9bv955"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:test-target "tests"))
+ (propagated-inputs (list ocaml-base ocaml-ppxlib))
+ (properties `((upstream-name . "ppx_disable_unused_warnings")))
+ (home-page "https://github.com/janestreet/ppx_disable_unused_warnings")
+ (synopsis "Simple ppx extension for commonly unused warnings")
+ (description "This package expands @code{@@disable_unused_warnings} into
+@code{@@warning \"-20-26-32-33-34-35-36-37-38-39-60-66-67\"}")
+ (license license:expat)))
+
(define-public ocaml-ppx-jane
(package
(name "ocaml-ppx-jane")