summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-29 15:19:38 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-15 16:33:45 +0200
commit35de1fbd909d0365ed20fe91e2815a35a74cdabe (patch)
tree53e4880db05ec4f73e73a9916c37c91596b5ca23
parentd072efcb6d58b580dc94267526d35780ad8e0417 (diff)
downloadguix-patches-35de1fbd909d0365ed20fe91e2815a35a74cdabe.tar
guix-patches-35de1fbd909d0365ed20fe91e2815a35a74cdabe.tar.gz
gnu: Add python-seaborn.
* gnu/packages/python.scm (python-seaborn, python2-seaborn): New variables.
-rw-r--r--gnu/packages/python.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f876ccfca8..e771e170d2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3523,6 +3523,41 @@ providing a clean and modern domain specific specification language (DSL) in
Python style, together with a fast and comfortable execution environment.")
(license license:expat)))
+(define-public python-seaborn
+ (package
+ (name "python-seaborn")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/s/seaborn/seaborn-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1236abw18ijjglmv60q85ckqrvgf5qyy4zlq7nz5aqfg6q87z3wc"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pandas" ,python-pandas)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-scipy" ,python-scipy)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://stanford.edu/~mwaskom/software/seaborn/")
+ (synopsis "Statistical data visualization")
+ (description
+ "Seaborn is a library for making attractive and informative statistical
+graphics in Python. It is built on top of matplotlib and tightly integrated
+with the PyData stack, including support for numpy and pandas data structures
+and statistical routines from scipy and statsmodels.")
+ (license bsd-3)))
+
+(define-public python2-seaborn
+ (let ((seaborn (package-with-python2 python-seaborn)))
+ (package (inherit seaborn)
+ (propagated-inputs
+ `(("python2-pytz" ,python2-pytz)
+ ,@(package-propagated-inputs seaborn))))))
+
(define-public python-sympy
(package
(name "python-sympy")