summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-05-01 07:54:59 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-05-01 13:14:55 +0200
commit044b42720d7c8117008302b23fbf248fa962de9e (patch)
treebf434dbac6e3e08d85b8e0d8f8a6fa42a2d3196f
parenta9e8b6e7a27e02e2457f55be2bcac1321b43fa19 (diff)
downloadguix-patches-044b42720d7c8117008302b23fbf248fa962de9e.tar
guix-patches-044b42720d7c8117008302b23fbf248fa962de9e.tar.gz
gnu: Add ocaml-ppx-ignore-instrumentation.
* gnu/packages/ocaml.scm (ocaml-ppx-ignore-instrumentation): New variable.
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 24a58fbe0e..680533072e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6584,6 +6584,31 @@ functions from type definitions.")
(properties '())
(license license:asl2.0))))
+(define-public ocaml-ppx-ignore-instrumentation
+ (package
+ (name "ocaml-ppx-ignore-instrumentation")
+ (version "0.15.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_ignore_instrumentation")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16fgig88g3jr0m3i636fr52h29h1yzhi8nhnl4029zn808kcdyj2"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:tests? #f)) ;no tests
+ (propagated-inputs (list ocaml-ppxlib))
+ (properties `((upstream-name . "ppx_ignore_instrumentation")))
+ (home-page "https://github.com/janestreet/ppx_ignore_instrumentation")
+ (synopsis "Ignore Jane Street specific instrumentation extensions")
+ (description
+ "Ignore Jane Street specific instrumentation extensions from internal
+PPXs or compiler features not yet upstreamed.")
+ (license license:expat)))
+
(define-public ocaml-ppx-jane
(package
(name "ocaml-ppx-jane")