summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-27 14:55:26 -0400
committerMark H Weaver <mhw@netris.org>2015-08-18 23:52:57 -0400
commitba139bd75bd783d2474e5f9ecc0dd6d3aac6a9c3 (patch)
treee4d061da8c1d4690a6f093d39629847b55f8ed05
parente41e013b1b9dc2fe0325c05e8819afea217fc0f7 (diff)
downloadguix-patches-ba139bd75bd783d2474e5f9ecc0dd6d3aac6a9c3.tar
guix-patches-ba139bd75bd783d2474e5f9ecc0dd6d3aac6a9c3.tar.gz
PRELIMINARY: gnu: Add ppp.
TODO: Fix 'license' field. * gnu/packages/networking.scm (ppp): New variable.
-rw-r--r--gnu/packages/networking.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index dc139e28fe..ac96b16d4e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,6 +23,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages admin)
#:use-module (gnu packages tls))
(define-public miredo
@@ -146,3 +147,40 @@ receiving NDP messages.")
auto-negotiation and checksum offload on many network devices, especially
Ethernet devices.")
(license license:gpl2)))
+
+(define-public ppp
+ (package
+ (name "ppp")
+ (version "2.4.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.samba.org/pub/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c7vrjxl52pdwi4ckrvfjr08b31lfpgwf3pp0cqy76a77vfs7q02"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:make-flags '("CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'unpack 'patch-pppd-makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "pppd/Makefile.linux"
+ (("/usr/include/crypt.h")
+ (string-append (assoc-ref inputs "libc")
+ "/include/crypt.h")))
+ #t)))))
+ (home-page "https://ppp.samba.org/")
+ (synopsis "Point-to-Point Protocol (PPP)")
+ (description
+ "The Point-to-Point Protocol provides a standard way to transmit
+datagrams over a serial link, as well as a standard way for the machines at
+either end of the link to negotiate various optional characteristics of the
+link.")
+ ;; XXX TODO Document all of the licenses.
+ (license (license:non-copyleft
+ "http://metadata.ftp-master.debian.org/changelogs//main/p/ppp/ppp_2.4.6-3.1_copyright"))))