summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-25 19:10:10 +0000
committerMathieu Othacehe <othacehe@gnu.org>2022-04-26 10:45:42 +0200
commitee89bbb5ed24cf22e2cbce50c4f328dd4d6c70dd (patch)
tree0e4f778b1b98b1588921320535208246dbd1f9df
parent33fe027f91062926c513c3b5f9a91ae761810f89 (diff)
downloadguix-patches-ee89bbb5ed24cf22e2cbce50c4f328dd4d6c70dd.tar
guix-patches-ee89bbb5ed24cf22e2cbce50c4f328dd4d6c70dd.tar.gz
gnu: nomad-optimizer: Disable failing test.
* gnu/packages/maths.scm (nomad-optimizer)[arguments]: Disable the examples/advanced/library/PSDMads test. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/maths.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f4778179d6..fcd9c5482f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -45,7 +45,7 @@
;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
-;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2021, 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
@@ -2008,6 +2008,10 @@ interfaces.")
(add-after 'fix-sources-for-build 'fix-sources-for-tests
(lambda _
(substitute* "examples/CMakeLists.txt"
+ ;; This test passes only sometimes.
+ ;; See https://github.com/bbopt/nomad/issues/72.
+ (("^ +add_subdirectory\\(\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/advanced/library/PSDMads\\)\n")
+ "")
;; examples/basic/batch/example3 is accidentally omitted.
(("^(add_subdirectory\\(\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/basic/batch/example)2(\\)\n)"
_ prefix suffix)
@@ -2052,10 +2056,6 @@ interfaces.")
"examples/advanced/library/exampleSuggestAndObserve/cache0.txt")
(let ((builddir (string-append (getcwd) "/../build")))
- ;; For some reason, omitting this fix causes the
- ;; examples/advanced/library/PSDMads test to fail, even though
- ;; it doesn't seem to reference any part of the FixedVariable
- ;; test.
(let ((dir "examples/advanced/library/FixedVariable"))
(substitute* (string-append dir "/fixedVariable.cpp")
(("^( +std::string sExe = ).*" _ prefix)