summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2022-04-19 07:26:54 +0000
committerMathieu Othacehe <othacehe@gnu.org>2022-04-27 11:20:00 +0200
commitb840c50b3fa44b5a08708e52fb28dbbd458f5449 (patch)
tree821c0e2f9b06fa1a5e4867c0448a61fe2909ca5d
parentb147a4a2f3186b499df6a21bfc9cc8c2a3ba0668 (diff)
downloadguix-patches-b840c50b3fa44b5a08708e52fb28dbbd458f5449.tar
guix-patches-b840c50b3fa44b5a08708e52fb28dbbd458f5449.tar.gz
gnu: Add wtime.
* gnu/packages/task-management.scm (wtime): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/task-management.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index c349081f01..65b3dc8699 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
(define-module (gnu packages task-management)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages check)
#:use-module (gnu packages freedesktop)
@@ -42,6 +44,7 @@
#:use-module (guix hg-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
#:use-module (guix build-system python))
@@ -242,6 +245,41 @@ to with the goal of improving your focus and enhancing your productivity.
You can also use it to fall asleep in a noisy environment.")
(license license:gpl3+)))
+(define-public wtime
+ (package
+ (name "wtime")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/wtime/wtime/"
+ version "/wtime_"
+ (string-replace-substring version "." "_")
+ ".tar.gz"))
+ (sha256
+ (base32 "1rp1sxas9wjc84fvr6x94ryl3r9w7jd0x5j1hbi9q7yrgfclp830"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ ,#~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-man-path
+ (lambda _
+ (substitute* "Makefile"
+ (("/man1") "/share/man/man1")))))
+ #:tests? #f)) ; No "check" target.
+ (home-page "http://wtime.sourceforge.net")
+ (synopsis
+ "Command-line utility for tracking time spent on arbitrary tasks")
+ (description
+ "@code{wtime} is a command-line utility for tracking time spent working
+on arbitrary tasks. All the time data is saved in files residing in the
+@code{.wtimed} directory in the user's home directory.")
+ (license license:x11)))
+
(define-public todoman
(package
(name "todoman")