summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-26 09:47:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-26 09:48:14 +0200
commit33fe027f91062926c513c3b5f9a91ae761810f89 (patch)
tree5e33b2b6973de024e6f48ebdd3924d9536680acc
parentb79431b5e98d33c23dea808d0aa9fd847e1471ab (diff)
downloadguix-patches-33fe027f91062926c513c3b5f9a91ae761810f89.tar
guix-patches-33fe027f91062926c513c3b5f9a91ae761810f89.tar.gz
gnu: Add r-giotto.
* gnu/packages/bioinformatics.scm (r-giotto): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4634b86515..40ccba247c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11972,6 +11972,64 @@ cells with similar identification cards in the different cytometric profiles
is then merged.")
(license license:gpl2))))
+(define-public r-giotto
+ (let ((commit "68d7390dce87223cac11d4d8f31705fe0144d011")
+ (revision "1"))
+ (package
+ (name "r-giotto")
+ (version (git-version "1.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/RubD/Giotto/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mv60khc05wrxzr4ir6cirn7dpqvgwan5hm00lmafsyalr51nf5i"))))
+ (properties `((upstream-name . "Giotto")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-clusterr
+ r-complexheatmap
+ r-cowplot
+ r-data-table
+ r-dbscan
+ r-deldir
+ r-farver
+ r-fitdistrplus
+ r-ggdendro
+ r-ggplot2
+ r-ggraph
+ r-ggrepel
+ r-igraph
+ r-irlba
+ r-lfa
+ r-limma
+ r-magick
+ r-magrittr
+ r-matrix
+ r-matrixstats
+ r-plotly
+ r-qvalue
+ r-r-utils
+ r-rcolorbrewer
+ r-rcpp
+ r-reshape2
+ r-reticulate
+ r-rfast
+ r-rlang
+ r-rtsne
+ r-scales
+ r-uwot))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/RubD/Giotto/")
+ (synopsis "Spatial single-cell transcriptomics toolbox")
+ (description
+ "This package provides a toolbox to process, analyze and visualize
+spatial single-cell expression data.")
+ (license license:expat))))
+
(define-public gffread
;; We cannot use the tagged release because it is not in sync with gclib.
;; See https://github.com/gpertea/gffread/issues/26