summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-04-24 23:50:36 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-04-26 09:20:04 +0200
commit5c450082f797beee5dc0c446010425aa0f191056 (patch)
treed43d9bc7d783cfa0fbfe2a0fac6af9eaa239b299
parente5098ad9b0c1223985ab96604fb0247130b011ae (diff)
downloadguix-patches-5c450082f797beee5dc0c446010425aa0f191056.tar
guix-patches-5c450082f797beee5dc0c446010425aa0f191056.tar.gz
gnu: guile-srfi-189: Build from upstream sources.
* gnu/packages/guile-xyz.scm (guile-srfi-189): Retarget git-reference to the official repo, and increase revision by one. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 863ebd17ea..ebecdfaa1e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3256,21 +3256,17 @@ API.")
(license license:expat))))
(define-public guile-srfi-189
- (let ((commit "a0e3786702956c9e510d92746474ac988c2010ec")
- (revision "0"))
+ (let ((commit "659e3cd0fc2bfca9085424eda8cad804ead2a9ea")
+ (revision "1"))
(package
(name "guile-srfi-189")
- (version (git-version "0" revision commit))
+ ;; 'final' is the name of the latest git tag.
+ (version (git-version "final" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
- ;; This is a fork of:
- ;; (url "https://github.com/scheme-requests-for-implementation/srfi-189")
- ;; Upstream merge requested at:
- ;; https://github.com/scheme-requests-for-implementation/srfi-189/pull/21
- ;; TODO switch over to the official repo when the PR gets merged
- (url "https://github.com/attila-lendvai-patches/srfi-189")
+ (url "https://github.com/scheme-requests-for-implementation/srfi-189")
(commit commit)))
(sha256
(base32