summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-17 10:13:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-26 09:48:13 +0200
commit2902adfc7e0e4e9526ead9d35be14ac4f9b77c1c (patch)
tree7db437a86e9ce0660f4d442acf5df17afd083851
parent63091319491e260ec1c510219e5a297d04b22109 (diff)
downloadguix-patches-2902adfc7e0e4e9526ead9d35be14ac4f9b77c1c.tar
guix-patches-2902adfc7e0e4e9526ead9d35be14ac4f9b77c1c.tar.gz
gnu: Add r-adam.
* gnu/packages/bioconductor.scm (r-adam): New variable.
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bec3496057..cd28d3eb20 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1581,6 +1581,41 @@ expression level and gene-specific dispersion, that might facilitate the gene
ranking by fold-change and visualization.")
(license license:gpl3+)))
+(define-public r-adam
+ (package
+ (name "r-adam")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ADAM" version))
+ (sha256
+ (base32
+ "18zwci0ab54q7rdwj0n63w0i14lfrb4cccp09bcrq10gl1ki07f5"))))
+ (properties `((upstream-name . "ADAM")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-dt
+ r-go-db
+ r-keggrest
+ r-knitr
+ r-pbapply
+ r-rcpp
+ r-stringr
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/ADAM")
+ (synopsis "Gene activity and diversity analysis module")
+ (description
+ "This software @code{ADAM} is a @dfn{Gene set enrichment analysis} (GSEA)
+package created to group a set of genes from comparative samples (control
+versus experiment) belonging to different species according to their respective
+functions. The corresponding roles are extracted from the default collections
+like Gene ontology and @dfn{Kyoto encyclopedia of genes and genomes} (KEGG).
+@code{ADAM} show their significance by calculating the p-values referring to
+gene diversity and activity. Each group of genes is called @dfn{Group of
+functionally associated genes} (GFAG).")
+ (license license:gpl2+)))
+
(define-public r-aneufinder
(package
(name "r-aneufinder")