summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Felipe <luis.felipe.la@protonmail.com>2022-04-23 14:14:43 -0500
committerMathieu Othacehe <othacehe@gnu.org>2022-04-26 11:07:51 +0200
commit58f3727767dc6b7ffd27d9cea87cf391845bbba6 (patch)
tree750a769c9cff111a2448a55c7532c012b78e06b7
parent30ff557bd7255dddec16f4a032e58f5a88d5e448 (diff)
downloadguix-patches-58f3727767dc6b7ffd27d9cea87cf391845bbba6.tar
guix-patches-58f3727767dc6b7ffd27d9cea87cf391845bbba6.tar.gz
gnu: gfeeds: Make it start.
This change patches the version of WebKit required by the program to a version available in Guix, so that the program actually starts. * gnu/packages/syndication.scm (gfeeds)[arguments]: Require WebKit2 4.1 instead of 4.0, which is not available. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/syndication.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 0417737d7d..20929aa7ad 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -537,6 +538,11 @@ formats, including all versions of RSS and Atom.")
(substitute* "gfeeds/confManager.py"
(("mpv") (search-input-file inputs "/bin/mpv")))
#t))
+ (add-after 'unpack 'patch-webkit2-version
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "bin/gfeeds.in"
+ (("gi\\.require_version\\('WebKit2', '4\\.0'\\)")
+ "gi.require_version('WebKit2', '4.1')"))))
(add-after 'install 'wrap-gfeeds
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (string-append