summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-26 09:42:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-26 09:48:13 +0200
commit190830bd806b2caec97eac9890bfeebad20a686a (patch)
tree6bc135e1d8f1246d658c77b6ac2668e3e419ff3f
parent2902adfc7e0e4e9526ead9d35be14ac4f9b77c1c (diff)
downloadguix-patches-190830bd806b2caec97eac9890bfeebad20a686a.tar
guix-patches-190830bd806b2caec97eac9890bfeebad20a686a.tar.gz
gnu: Add r-dbscan.
* gnu/packages/cran.scm (r-dbscan): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bc95eee065..21cfca3102 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -252,6 +252,35 @@ clean, transform, and prepare your data for analysis. It also forms the data
wrangling backend for the packages in the @code{easystats} ecosystem.")
(license license:gpl3)))
+(define-public r-dbscan
+ (package
+ (name "r-dbscan")
+ (version "1.1-10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dbscan" version))
+ (sha256
+ (base32 "1h8x1v9kk5zmw5qd575cyr16yz8l226lsaq71n079l4i8crcrzg1"))))
+ (properties `((upstream-name . "dbscan")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mhahsler/dbscan")
+ (synopsis "Density-based spatial clustering of applications with noise")
+ (description
+ "This package provides a fast reimplementation of several density-based
+algorithms of the DBSCAN family. It includes the clustering algorithms DBSCAN
+(density-based spatial clustering of applications with noise) and
+@dfn{hierarchical DBSCAN} (HDBSCAN), the ordering algorithm @dfn{ordering
+points to identify the clustering structure} (OPTICS), shared nearest neighbor
+clustering, and the outlier detection algorithms @dfn{local outlier
+factor} (LOF) and @dfn{global-local outlier score from hierarchies} (GLOSH).
+The implementations use the kd-tree data structure for faster k-nearest
+neighbor search. An R interface to fast kNN and fixed-radius NN search is
+also provided.")
+ (license license:gpl2+)))
+
(define-public r-diffobj
(package
(name "r-diffobj")