summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-04-15 15:53:32 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-20 23:46:45 +0200
commited2e797750f17833761c5a2816551e06cffd3f78 (patch)
tree299051a1c0e6831dd8095e21ec82575ca736829d
parentbd6e9be532e0563339d9e4b1344993a5677dc5fe (diff)
downloadguix-patches-ed2e797750f17833761c5a2816551e06cffd3f78.tar
guix-patches-ed2e797750f17833761c5a2816551e06cffd3f78.tar.gz
gnu: Add pikchr.
* gnu/packages/pikchr.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/pikchr.scm59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 798b7027b2..9bad87710c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -474,6 +474,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/phabricator.scm \
%D%/packages/php.scm \
%D%/packages/piet.scm \
+ %D%/packages/pikchr.scm \
%D%/packages/pkg-config.scm \
%D%/packages/plan9.scm \
%D%/packages/plotutils.scm \
diff --git a/gnu/packages/pikchr.scm b/gnu/packages/pikchr.scm
new file mode 100644
index 0000000000..5a26b11ac6
--- /dev/null
+++ b/gnu/packages/pikchr.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 pukkamustard <pukkamustard@posteo.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pikchr)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public pikchr
+ (let ((commit "221988914eff6efe")
+ (revision "0")) ;increment for each new snapshot
+ (package
+ (name "pikchr")
+ ;; To update, use the last check-in in https://pikchr.org/home/timeline?r=trunk
+ (version (string-append revision "-" (string-take commit 5)))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://pikchr.org/home/tarball/" commit
+ "/pikchr.tar.gz"))
+ (file-name (string-append "pikchr-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0yclkincsgfni4scjzp5avdsij8vmyxjn0q2qkwjhn3p43y8nxzd"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "pikchr" bin)))))))
+ (home-page "https://pikchr.org")
+ (synopsis "Markup language for diagrams in technical documentation")
+ (description
+ "Pikchr (pronounced @emph{picture}) is a PIC-like markup language for
+diagrams in technical documentation. Pikchr is designed to be embedded in
+fenced code blocks of Markdown or similar mechanisms of other documentation
+markup languages.")
+ (license license:bsd-0))))