summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-04-14 16:44:02 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-20 23:46:44 +0200
commitd2cb3f99057a53e32d97bde423de4eb81bf9df5b (patch)
treebdb875266ca98234f7f7cd571b0c0281b1657b28
parentfbf143558764c070437bf2b7f1db1046c95c0d5b (diff)
downloadguix-patches-d2cb3f99057a53e32d97bde423de4eb81bf9df5b.tar
guix-patches-d2cb3f99057a53e32d97bde423de4eb81bf9df5b.tar.gz
gnu: aws-c-auth: Update to 0.6.11.
* gnu/packages/c.scm (aws-c-auth): Update to 0.6.11. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/c.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 280811eaec..2e188af3f3 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -837,7 +837,7 @@ currently limited to Huffman encoding and decoding.")
(package
(name "aws-c-auth")
; Update only when updating aws-crt-cpp.
- (version "0.6.4")
+ (version "0.6.11")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -846,7 +846,7 @@ currently limited to Huffman encoding and decoding.")
(file-name (git-file-name name version))
(sha256
(base32
- "120p69lj279yq3d2b81f45kgfrvf32j6m7s03m8hh27w8yd4vbfp"))
+ "0frfnbifkrib9l68mj92a3g1x8xc8hpdlzbga2a801zgf2flx4fy"))
(patches
(search-patches
"aws-c-auth-install-private-headers.patch"))))
@@ -858,7 +858,7 @@ currently limited to Huffman encoding and decoding.")
(assoc-ref %build-inputs "aws-c-common"))
"-DENABLE_NET_TESTS=OFF")))
(propagated-inputs
- (list aws-c-cal aws-c-common aws-c-http aws-c-io))
+ (list aws-c-cal aws-c-common aws-c-http aws-c-io aws-c-sdkutils))
(synopsis "Amazon Web Services client-side authentication library")
(description
"This library provides a C99 implementation for AWS client-side