summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2022-04-09 20:42:10 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-20 23:46:45 +0200
commitcd5c31d192453c071d5384ea1eabbf02c9708758 (patch)
treeff2ee3c6a15b04cc7004e8f0b48204a79a50561e
parented2e797750f17833761c5a2816551e06cffd3f78 (diff)
downloadguix-patches-cd5c31d192453c071d5384ea1eabbf02c9708758.tar
guix-patches-cd5c31d192453c071d5384ea1eabbf02c9708758.tar.gz
gnu: Add emacs-cpreproc.
* gnu/packages/emacs-xyz.scm (emacs-cpreproc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 519f40291e..20ee373636 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -74,7 +74,7 @@
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
-;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
+;;; Copyright © 2020, 2022 Fredrik Salomonsson <plattfot@posteo.net>
;;; Copyright © 2020 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Peng Mei Yu <i@pengmeiyu.com>
@@ -22098,6 +22098,29 @@ Pandoc, the document-conversion tool.")
and @code{C++} files through the @code{ccls} language server.")
(license license:expat))))
+(define-public emacs-cpreproc
+ (package
+ (name "emacs-cpreproc")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~plattfot/cpreproc")
+ (commit version)))
+ (sha256
+ (base32
+ "0n4lhj9bbnkbzvifrj9q6z3j7z6jqzkaa36y239cfxdcc7i86c1c"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://sr.ht/~plattfot/cpreproc")
+ (synopsis "Wrap C/C++ code in preprocessor macros")
+ (description
+ "Aim for this project is to make it easier to generate preprocessor macros
+from Emacs for C/C++ code that needs to be build against multiple incompatible
+versions of third party libraries or @code{C++} standards.")
+ (license license:gpl3+)))
+
(define-public emacs-org-brain
(package
(name "emacs-org-brain")