summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-21 04:18:41 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-23 10:06:18 +0200
commita58734e7fea0015ba113be068d0aebf67dd8afdb (patch)
tree6ad292ce64142899d966f1dd66fb6a12adf952fb
parent7134a1081379e9950387e9ff581e48bc92939eba (diff)
downloadguix-patches-a58734e7fea0015ba113be068d0aebf67dd8afdb.tar
guix-patches-a58734e7fea0015ba113be068d0aebf67dd8afdb.tar.gz
gnu: Add cl-bobbin.
* gnu/packages/lisp-xyz.scm (sbcl-bobbin, cl-bobbin, ecl-bobbin): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0c7d9b3848..ab63fce9fc 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1528,6 +1528,41 @@ and macros, primarily for software projects written in CL by the author.")
(define-public cl-piping
(sbcl-package->cl-source-package sbcl-piping))
+(define-public sbcl-bobbin
+ (let ((commit "b454e8241b24ceab674eeeae464c8082b1b6d8ce")
+ (revision "0"))
+ (package
+ (name "sbcl-bobbin")
+ (version (git-version "1.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sjl/bobbin")
+ (commit commit)))
+ (file-name (git-file-name "cl-bobbin" version))
+ (sha256
+ (base32 "02lw7w8cbvnxw5acbz405rb5lcqsf4fx7dvj5ldr0lhgbyv1mjnm"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ (list sbcl-1am))
+ (inputs
+ (list sbcl-split-sequence))
+ (home-page "https://docs.stevelosh.com/bobbin/")
+ (synopsis "Simple (word) wrapping utilities for strings")
+ (description
+ "Bobbin is a simple word-wrapping library for strings in Common Lisp.
+It aims to be simple, work nicely for the majority of cases, and degrade
+gracefully for edge cases. It is not particularly concerned with speed — if
+you need very high-performance word wrapping, Bobbin is not for you.")
+ (license license:expat))))
+
+(define-public cl-bobbin
+ (sbcl-package->cl-source-package sbcl-bobbin))
+
+(define-public ecl-bobbin
+ (sbcl-package->ecl-package sbcl-bobbin))
+
(define-public sbcl-cl-pcg
(let ((commit "8263d85ab0ca17fb05637a4430c2d564456bce8f")
(revision "1"))